Phone Support Problem
Incident Report for ServInt
Resolved
This issue was resolved by our provider. Our phone numbers should be fully operational again. We appreciate your patience.
Posted over 2 years ago. Nov 12, 2014 - 17:48 EST
Investigating
One of our providers for phone support is experiencing connectivity problems. We are working with them to solve this, but our phone system might be inaccessible until this is solved. No other systems are affected. Please feel free to open a support ticket if you need support in the interim.
Posted over 2 years ago. Nov 12, 2014 - 16:30 EST